MUST BE 18 OR OLDER - MUST READ TERMS OF SERVICE

Know an inmate being released within the year who's in need of a job? We are working with employers to help find inmates work before they're released. Post a free Employment Profile for an inmate here!

Problems with ConnectNetwork

7 posts / 0 new
Last post
jtrocaire
jtrocaire's picture
Problems with ConnectNetwork

Hi everyone,

First off, thank you to everyone who posts in the forum. It's really helped me get the hang of this whole penpal thing and I'm so glad since it's been a super rewarding experience so far!

Ok, I have two questions:

1. I made a ConnectNetwork account but whenever I try to log on to the mobile app, it says my credentials failed but my password works on the webpage. When I try to log on to the web app, I either get redirected to an error page instead of a login page or I get redirected to Telmate (I could login there but my PP isn't listed). Is anyone else having similar issues? I tried to contact customer support but haven't heard back yet.

2. Is anyone else having issues seeing forum posts since the site maintenance? Any posts I click on are empty...

Thanks for the help!

Suvikki
Suvikki's picture

I can see that others are commented but I can´t see what, it´s all blank.

ST4s
ST4s's picture

Hey jtrocaire, glad to hear about the super rewarding part! To your questions:

My recent experience with the Connect Network login page (the web browser version) is it makes you log in twice. After the first time, it takes you to a screen where you have to enter your birthdate, e.g. establish you’re not a minor, and then you login again. After you're in, every now and then, especially when composing e-messages, it kicks you out and you get to start the fun all over again! I haven’t had any problems with the smartphone app though.

Yeah, the forum posts were all blank for a while, but now they seem to be back. One empathizes with the tech squad. Bet THAT freaked ‘em out!  

jtrocaire
jtrocaire's picture

Hi ST4s! Hmm... I did notice that birthdate thing before but my issue is that I can't login after creating the account (i.e. it won't accept my email and password combo). Does it matter if the address I gave is outside of the US? Have you been able to login this week?

jtrocaire
jtrocaire's picture

I'm so glad the forum is back!! I agree.. it must have induced some panic! I can finally also search for past posts about Connect Network, maybe someone has had the same issue!

Suvikki
Suvikki's picture

Thank you, now this is working. Good job!  Greetings from Finland. 

ChloeOlivia
ChloeOlivia's picture

Hi. I'm having the same issue! I've tried for a few weeks now.. did you have any luck and if so please can you help me. I'm doing it from the UK